Submitter | Myles Watson |
---|---|
Date | 2009-10-07 19:42:12 |
Message ID | <2831fecf0910071242w1d7e65eakab9859bb64abdba3@mail.gmail.com> |
Download | mbox | patch |
Permalink | /patch/364/ |
State | Accepted |
Headers | show |
Comments
On Wed, Oct 07, 2009 at 01:42:12PM -0600, Myles Watson wrote: > On Wed, Oct 7, 2009 at 1:32 PM, Uwe Hermann <uwe@hermann-uwe.de> wrote: > > See patch. > Index: src/mainboard/intel/xe7501devkit/irq_tables.c > =================================================================== > --- src/mainboard/intel/xe7501devkit/irq_tables.c (Revision 4738) > +++ src/mainboard/intel/xe7501devkit/irq_tables.c (Arbeitskopie) > @@ -20,7 +20,7 @@ > const struct irq_routing_table intel_irq_routing_table = { > PIRQ_SIGNATURE, > PIRQ_VERSION, > - 32 + 12*sizeof(struct irq_info), // Size of this struct in bytes > + 32 + 16 * CONFIG_IRQ_SLOT_COUNT, // Size of this struct in bytes > > I like the sizeof. It removes one magic number. Yeah, might be worth considering, but we should do a mass-change in all files then. Probably low-priority right now, though. > Acked-by: Myles Watson <mylesgw@gmail.com> Thanks, r4739. Uwe.
Patch
Index: src/mainboard/intel/xe7501devkit/irq_tables.c =================================================================== --- src/mainboard/intel/xe7501devkit/irq_tables.c (Revision 4738) +++ src/mainboard/intel/xe7501devkit/irq_tables.c (Arbeitskopie) @@ -20,7 +20,7 @@ const struct irq_routing_table intel_irq_routing_table = { PIRQ_SIGNATURE, PIRQ_VERSION, - 32 + 12*sizeof(struct irq_info), // Size of this struct in bytes + 32 + 16 * CONFIG_IRQ_SLOT_COUNT, // Size of this struct in bytes I like the sizeof. It removes one magic number.